The Problem

ERROR 3167 (HY000) at line 17: The ‘INFORMATION_SCHEMA.SESSION_VARIABLES’ feature is disabled; see the documentation for ‘show_compatibility_56’

This is a common issue that use to appear when you are trying to execute a SQL script created on MySQL 5.6 in a higher MySQL version.

Due to latest MySQL changes, ‘INFORMATION_SCHEMA.SESSION_VARIABLES’ has been deprecated and will be removed in future releases.

The Solution

So, in order to workaround it, this is what you need to do to be able to execute your SQL script.

You must be logged with a user with super privileges in order to perform this action.

In conclusion, you need to turn mysql 5.6 compatibility on to perform this action.

Leave a comment